Adobe Creative Cloud Connector

  • Updated
The Creative Cloud Connector allows you to search, filter, and check asset details metadata and access your Collections that live in your DAM directly within Adobe Creative Cloud without leaving Adobe. This Connector saves time and ensures the latest versions of your assets live in Bynder. This Connector can be used in InDesign, Photoshop, and Illustrator. When your Adobe file is ready, you can upload it to Bynder directly using the Connector.  
 

How to enable this feature?

Contact your Customer Success Manager to learn more about enabling this integration and any associated costs. An annual license fee is required to use the plugin. If you are interested in a trial, contact your Customer Success Manager. The trial is valid for 30 days. 

Supported Versions

Bynder supports CC2024 &  CC2023. The plugin does not support 32-bit Windows. The plugin does not require Java or a specific version of a browser.

Version Updates

The CC Connector automatically detects when a new version of an asset is uploaded to Bynder. The Screenshot 2024-01-02 at 12.35.53 PM.png symbol in the Links tab will notify you that a new version is available. Click the symbol to update to the latest version automatically.

Before you Install

Ensure all Adobe Creative Cloud projects are saved, and applications are closed before installing the Connector. 

How to Download and Install the Connector

  1. Click one of the available download links below to download the Adobe Creative Cloud Connector.
  1. Download and install the packages.
  2. Once the download is complete and packages are installed, open Adobe Creative Cloud.
  3. From the main InDesign menu, choose Window > Extensions > Bynder CC Connector.
  4. Enter your license key.
  5. In the Setup popup, enter the server name and the URL. The name and the URL in the screenshot are examples.

    Note

    Ensure the URL is the same as the one showing on the login page to the environment. If the URL is incorrect, you will get a Type =500 error when connecting.

    connector.png
  6. Click Add Server to list.
  7. Make sure the Bynder metaproperties you use as filters in the plugin and have the Apifilter option selected. If they do not, they will not be visible as filters in the plugin.

How to Use Connector

  1. From the main Creative Cloud menu, choose Window > Extensions > Bynder CC Connector.
  2. Select the Server from the Server list and click Connect. The browser will open, and you'll be redirected to the portal's login page. If you are getting a Type =500 error, it means the URL of the environment you are connecting to is incorrect.
  3. Log in to Bynder using SSO or your credentials.
  4. Click Yes to grant the Adobe CC Connector (Silicon Publishing) access to your portal. Once the authorization is successful, you can close the browser window/tab.
  5. To find your asset, expand the Filter drop-down list and select the filters you want to use. Close the filter drop-down list to see the applied filters. You can expand your search by clicking the X icon on the filter. Alternatively, you can use the search bar to look for specific assets.

    filters-bynder-cc-connector.png

  6. (Optional) Switch between the list and the grid view and use the available filters to sort the results by filename (alphabetical) or date added and ascending or descending.

    view-bynder-cc-connector.png

  7. Drag and drop the image into your InDesign, Photoshop, or Illustrator file. You can resize the image if needed. 

  8. You can see the first 100 images loaded. If you want to load more, click the + icon at the bottom of the page. The assets you see and use in InDesign depend on your permissions in Bynder.

  9. (Optional) To download a copy of an image from Bynder CC Connector to your computer, double-click the image you want to save and click the download_adobe_cc_connector.png to start downloading. This option is only available if the Save to Bynder_files folder option is enabled under preferences. 

    adobe-cc-plugin.png 

     

Importing Assets 

Importing images from Bynder means importing a link. When you import a Bynder Asset to Creative Cloud, it is automatically saved to the Bynder_connector_files > Documents folder. You can also upload a new asset to Bynder from your disk using the Upload from Disk option.

Saving Assets 

To save your downloaded image to another location, go to Preferences and clear the Save to Bynder_files folder preference under Download Options. You can now choose a location whenever a file is downloaded. You can select the option to Open the file on download (if possible), which will automatically open a downloaded image when the file has completed downloading.

Deleting Assets in Bynder

If you delete a Bynder Asset you used in an InDesign file, the asset will no longer display in InDesign.

Select the Resolution Used for Previewing Bynder Assets

You can switch between a high-res and low-res preview version of your Bynder assets in InDesign. Using low-res preview files can increase performance in InDesign.

  1. Go to Windows > Links to enable the Links panel in your workspace.
  2. Click menu_cc_connector.pngin the Links panel and click Panel Options. A new screen will open.
  3. Scroll to the Bynder option and select the Show column and Show in Link Info check boxes to add the Bynder Links tab options to your Links palette. This way, you can view and control your document's low-res and high-res state of assets. panel-options.png
  4. Toggle between low-res (stair-step icon) and high-res versions of your added images by double-clicking the resolution icon in the Links tab.

    resolution_cc_connector.png

How to Upload Adobe InDesign Files & Ingredients to Bynder

You can store your Adobe InDesign and ingredient files in Bynder and link them to their related Bynder assets.

Upload InDesign Files to Bynder

Follow the steps below to upload your InDesign file to Bynder. All the ingredient files linked to your Bynder portal will remain linked. This way, other users who open the InDesign file and install the Adobe CC Connector won't experience any missing links.

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.
  2. Click the menu_cc_connector.png in the Bynder CC Connector window and click Save file to Bynder.

  3. The file will be uploaded to your portal. It may take a while before it's available in the portal and Adobe CC Connector.

Upload a Specific InDesign Ingredient File to Bynder

Follow the steps below if a specific ingredient file isn't available in your Bynder portal.

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Select the image in your document that you want to upload to Bynder.

  3. Click the button in the Bynder CC Connector window and click Upload Selected.

  4. The file will be uploaded to your portal. It may take a while before it's available in the portal and Adobe CC Connector.

Upload All InDesign Ingredient Files to Bynder

Follow the steps below if you want to upload all ingredient files that aren't available in your Bynder portal yet.

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.
  2. Click the menu_cc_connector.png button in the Bynder CC Connector window and click Upload all non-HTTP Assets.
  3. The files will be uploaded to your portal. It may take a while before they're available in the portal and Adobe CC Connector.

Relink your InDesign Ingredient Files to Bynder

If you added an image stored locally on your device to your InDesign document, you can relink the file and ensure that the ingredient file is connected to the Bynder asset. This way, other Adobe CC Connector users won't experience any missing links if they open your InDesign document.

 

Relink One Ingredient File

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.
  2. Select the image in your document that you want to relink to a Bynder asset.
  3. Locate the Bynder asset in the Bynder CC Connector window using the available filters and search bar.
  4. Right-click the Bynder asset and click Relink to Asset.

Relink Multiple Ingredient File

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.
  2. Check the total number of assets available in the Adobe CC Connector panel. You can find this number at the bottom of the panel.
    • If the number is higher than 1000, use the available filters and search bar to narrow this number down to 1000 assets or less. This is necessary because the Connector can only search through a maximum number of 1000 assets when relinking.
  3. Click the menu_cc_connector.png button in the Bynder CC Connector window, click Relink Assets, and wait for the Connector to finish the relinking process.

Derivatives

No additional derivative configuration is required for the plugin. The Connector makes use of the default smaller derivative for image previewing. The plugin will use the original file when you add images to your InDesign, Photoshop, or Illustrator file. No other (custom) derivatives can be added to your InDesign, Photoshop, or Illustrator file via the plugin.

Preferences

preferenes-bynder-cc-connector.png

Place Options

  • Select Place Options > Replace selection on the place to replace an already selected image in the file by dragging and dropping another image. If the option has been cleared, you cannot replace images by dragging and dropping a new image.

  • Select Place Options > Use high resolution on place to automatically use a full-resolution version of the asset you add to your document. If you want to work with low-res images, clear this option.

Download Options

You cannot use the Adobe CC connector to download your Bynder assets if this option is not enabled.

  • Select Open file on download if you want the files to automatically open after download.
  • Select Save to Bynder_files folder if you want to download your Bynder assets using the Connector and store them locally.

Asset View

  • Select Use Grid view if you want the assets in the Adobe CC Connector to be displayed in a grid.
  • Select Use List view if you want the assets in the Adobe CC Connector to be displayed in a list.

Troubleshooting

  • Select the Write to log file option if you want the activity in the Adobe CC Connector to be logged. A log file can help better troubleshoot any issues you encounter using the Connector. You can clear the log by clicking the Clear Log File button.

Uninstall the Connector

  • To clear your saved credentials, log out of the Bynder Connector.

To Clear your Preferences

  1. Navigate to your Documents folder.
  2. Delete Bynder_connector_files folder.

To Deactivate the License to Use Again in the Future

  1. In the top menu bar, click Bynder and click Deactivate.
deactivate-licence.png

Mac Users

Log out from InDesign and remove the following folders:

  1. Remove the extension folder /Libraries/ApplicationSupport/Adobe/CEP/extensions/BynderCCConnector.
  2. Remove the plugin folder: /Applications/Adobe InDesign CC 201X/Plug-Ins/SiliconConnectorBynder. (The folder name depends on your version)

Window Users

  1. Quit InDesign.
  2. Navigate to Control Panel > Programs > Uninstall a Program and uninstall any previous Bynder Creative Cloud Connector installations.

    Note

    Before sending the package, ensure the files in your Links folder have extensions. If they miss anything, manually add .jpeg to your files in the folder. Send the entire package when you send your InDesign file to the printer.

Was this article helpful?

0 out of 0 found this helpful

We're sorry to hear that!

Find out more in our community

Have more questions? Find out more in our community